Ubuntu18.04LTSにLiteSpeedをインストール

ubuntuログイン Developer
ubuntuログイン
LiteSpeedのインストール

コマンドを打っている行はubuntu@で検索して下さい。

リポジトリの追加

ubuntu@i-11100000125436:~$ cd /tmp
ubuntu@i-11100000125436:/tmp$ wget http://rpms.litespeedtech.com/debian/enable_lst_debian_repo.sh
--2020-10-14 02:38:34--  http://rpms.litespeedtech.com/debian/enable_lst_debian_repo.sh
Resolving rpms.litespeedtech.com (rpms.litespeedtech.com)... 34.210.113.18
Connecting to rpms.litespeedtech.com (rpms.litespeedtech.com)|34.210.113.18|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3644 (3.6K) [application/x-sh]
Saving to: ‘enable_lst_debian_repo.sh’

enable_lst_debian_repo.sh     100%[=================================================>]   3.56K  --.-KB/s    in 0.007s

2020-10-14 02:38:35 (539 KB/s) - ‘enable_lst_debian_repo.sh’ saved [3644/3644]

ubuntu@i-11100000125436:/tmp$ chmod +x enable_lst_debian_repo.sh
ubuntu@i-11100000125436:/tmp$ sudo ./enable_lst_debian_repo.sh
 detecting OS type :
detected OS: ubuntu - 18.04
 now enable the LiteSpeed Debian Repo
 register LiteSpeed GPG key
--2020-10-14 02:40:43--  http://rpms.litespeedtech.com/debian/lst_debian_repo.gpg
Resolving rpms.litespeedtech.com (rpms.litespeedtech.com)... 34.210.113.18
Connecting to rpms.litespeedtech.com (rpms.litespeedtech.com)|34.210.113.18|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1198 (1.2K) [application/octet-stream]
Saving to: ‘/etc/apt/trusted.gpg.d/lst_debian_repo.gpg’

/etc/apt/trusted.gpg.d/lst_de 100%[=================================================>]   1.17K  --.-KB/s    in 0s

2020-10-14 02:40:43 (113 MB/s) - ‘/etc/apt/trusted.gpg.d/lst_debian_repo.gpg’ saved [1198/1198]

--2020-10-14 02:40:43--  http://rpms.litespeedtech.com/debian/lst_repo.gpg
Resolving rpms.litespeedtech.com (rpms.litespeedtech.com)... 34.210.113.18
Connecting to rpms.litespeedtech.com (rpms.litespeedtech.com)|34.210.113.18|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2336 (2.3K) [application/octet-stream]
Saving to: ‘/etc/apt/trusted.gpg.d/lst_repo.gpg’

/etc/apt/trusted.gpg.d/lst_re 100%[=================================================>]   2.28K  --.-KB/s    in 0s

2020-10-14 02:40:43 (198 MB/s) - ‘/etc/apt/trusted.gpg.d/lst_repo.gpg’ saved [2336/2336]

 update the repo
Ign:1 http://rpms.litespeedtech.com/debian bionic InRelease
Get:2 http://rpms.litespeedtech.com/debian bionic Release [1653 B]
Get:3 http://rpms.litespeedtech.com/debian bionic Release.gpg [836 B]
Hit:4 http://archive.ubuntu.com/ubuntu bionic InRelease
Get:5 http://rpms.litespeedtech.com/debian bionic/main amd64 Packages [19.8 kB]
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:7 http://archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:8 http://archive.ubuntu.com/ubuntu bionic-backports InRelease
Fetched 22.3 kB in 1s (17.9 kB/s)
Reading package lists... Done
 All done, congratulations and enjoy !

パッケージのインストール

ubuntu@i-11100000125436:/tmp$ sudo apt install openlitespeed
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  aspell aspell-en dictionaries-common emacsen-common enchant hunspell-en-us libaspell15 libc-client2007e
  libenchant1c2a libhunspell-1.6-0 libjpeg-turbo8 libjpeg8 libsodium23 libwebp6 libxpm4 libzip4 lsphp73 lsphp73-common
  lsphp73-imap lsphp73-json lsphp73-mysql lsphp73-opcache mlock php-common php-readline php7.2-common php7.2-readline
  rcs
Suggested packages:
  aspell-doc spellutils wordlist hunspell openoffice.org-hunspell | openoffice.org-core uw-mailutils libenchant-voikko
  php-pear php-user-cache
The following NEW packages will be installed:
  aspell aspell-en dictionaries-common emacsen-common enchant hunspell-en-us libaspell15 libc-client2007e
  libenchant1c2a libhunspell-1.6-0 libjpeg-turbo8 libjpeg8 libsodium23 libwebp6 libxpm4 libzip4 lsphp73 lsphp73-common
  lsphp73-imap lsphp73-json lsphp73-mysql lsphp73-opcache mlock openlitespeed php-common php-readline php7.2-common
  php7.2-readline rcs
0 upgraded, 29 newly installed, 0 to remove and 0 not upgraded.
Need to get 20.7 MB of archives.
After this operation, 92.3 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73-common all 7.3.22-1+bionic [31.5 kB]
Get:2 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73-json amd64 7.3.22-1+bionic [19.0 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libjpeg-turbo8 amd64 1.5.2-0ubuntu5.18.04.4 [110 kB]
Get:4 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73-opcache amd64 7.3.22-1+bionic [183 kB]
Get:5 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73 amd64 7.3.22-1+bionic [8796 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libaspell15 amd64 0.60.7~20110707-4ubuntu0.1 [309 kB]
Get:7 http://archive.ubuntu.com/ubuntu bionic/main amd64 emacsen-common all 2.0.8 [17.6 kB]
Get:8 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73-imap amd64 7.3.22-1+bionic [29.6 kB]
Get:9 http://archive.ubuntu.com/ubuntu bionic/main amd64 dictionaries-common all 1.27.2 [186 kB]
Get:10 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp73-mysql amd64 7.3.22-1+bionic [44.0 kB]
Get:11 http://rpms.litespeedtech.com/debian bionic/main amd64 openlitespeed amd64 1.6.16-1+bionic [8079 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 aspell amd64 0.60.7~20110707-4ubuntu0.1 [87.6 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic/main amd64 aspell-en all 2017.08.24-0-0.1 [298 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic/main amd64 hunspell-en-us all 1:2017.08.24 [168 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic/main amd64 libhunspell-1.6-0 amd64 1.6.2-1 [154 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic/main amd64 libenchant1c2a amd64 1.6.0-11.1 [64.4 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic/main amd64 enchant amd64 1.6.0-11.1 [12.2 kB]
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 mlock amd64 8:2007f~dfsg-5ubuntu0.18.04.2 [11.6 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 libc-client2007e amd64 8:2007f~dfsg-5ubuntu0.18.04.2 [582 kB]
Get:20 http://archive.ubuntu.com/ubuntu bionic/main amd64 libjpeg8 amd64 8c-2ubuntu8 [2194 B]
Get:21 http://archive.ubuntu.com/ubuntu bionic/main amd64 libsodium23 amd64 1.0.16-2 [143 kB]
Get:22 http://archive.ubuntu.com/ubuntu bionic/main amd64 libwebp6 amd64 0.6.1-2 [185 kB]
Get:23 http://archive.ubuntu.com/ubuntu bionic/main amd64 libxpm4 amd64 1:3.5.12-1 [34.0 kB]
Get:24 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libzip4 amd64 1.1.2-1.1 [37.8 kB]
Get:25 http://archive.ubuntu.com/ubuntu bionic/universe amd64 rcs amd64 5.9.4-4 [186 kB]
Get:26 http://archive.ubuntu.com/ubuntu bionic/main amd64 php-common all 1:60ubuntu1 [12.1 kB]
Get:27 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-common amd64 7.2.24-0ubuntu0.18.04.6 [888 kB]
Get:28 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 php7.2-readline amd64 7.2.24-0ubuntu0.18.04.6 [12.2 kB]
Get:29 http://archive.ubuntu.com/ubuntu bionic/universe amd64 php-readline all 1:7.2+60ubuntu1 [2000 B]
Fetched 20.7 MB in 8s (2676 kB/s)
Preconfiguring packages ...
Selecting previously unselected package libjpeg-turbo8:amd64.
(Reading database ... 90803 files and directories currently installed.)
Preparing to unpack .../00-libjpeg-turbo8_1.5.2-0ubuntu5.18.04.4_amd64.deb ...
Unpacking libjpeg-turbo8:amd64 (1.5.2-0ubuntu5.18.04.4) ...
Selecting previously unselected package libaspell15:amd64.
Preparing to unpack .../01-libaspell15_0.60.7~20110707-4ubuntu0.1_amd64.deb ...
Unpacking libaspell15:amd64 (0.60.7~20110707-4ubuntu0.1) ...
Selecting previously unselected package emacsen-common.
Preparing to unpack .../02-emacsen-common_2.0.8_all.deb ...
Unpacking emacsen-common (2.0.8) ...
Selecting previously unselected package dictionaries-common.
Preparing to unpack .../03-dictionaries-common_1.27.2_all.deb ...
Adding 'diversion of /usr/share/dict/words to /usr/share/dict/words.pre-dictionaries-common by dictionaries-common'
Unpacking dictionaries-common (1.27.2) ...
Selecting previously unselected package aspell.
Preparing to unpack .../04-aspell_0.60.7~20110707-4ubuntu0.1_amd64.deb ...
Unpacking aspell (0.60.7~20110707-4ubuntu0.1) ...
Selecting previously unselected package aspell-en.
Preparing to unpack .../05-aspell-en_2017.08.24-0-0.1_all.deb ...
Unpacking aspell-en (2017.08.24-0-0.1) ...
Selecting previously unselected package hunspell-en-us.
Preparing to unpack .../06-hunspell-en-us_1%3a2017.08.24_all.deb ...
Unpacking hunspell-en-us (1:2017.08.24) ...
Selecting previously unselected package libhunspell-1.6-0:amd64.
Preparing to unpack .../07-libhunspell-1.6-0_1.6.2-1_amd64.deb ...
Unpacking libhunspell-1.6-0:amd64 (1.6.2-1) ...
Selecting previously unselected package libenchant1c2a:amd64.
Preparing to unpack .../08-libenchant1c2a_1.6.0-11.1_amd64.deb ...
Unpacking libenchant1c2a:amd64 (1.6.0-11.1) ...
Selecting previously unselected package enchant.
Preparing to unpack .../09-enchant_1.6.0-11.1_amd64.deb ...
Unpacking enchant (1.6.0-11.1) ...
Selecting previously unselected package mlock.
Preparing to unpack .../10-mlock_8%3a2007f~dfsg-5ubuntu0.18.04.2_amd64.deb ...
Unpacking mlock (8:2007f~dfsg-5ubuntu0.18.04.2) ...
Selecting previously unselected package libc-client2007e.
Preparing to unpack .../11-libc-client2007e_8%3a2007f~dfsg-5ubuntu0.18.04.2_amd64.deb ...
Unpacking libc-client2007e (8:2007f~dfsg-5ubuntu0.18.04.2) ...
Selecting previously unselected package libjpeg8:amd64.
Preparing to unpack .../12-libjpeg8_8c-2ubuntu8_amd64.deb ...
Unpacking libjpeg8:amd64 (8c-2ubuntu8) ...
Selecting previously unselected package libsodium23:amd64.
Preparing to unpack .../13-libsodium23_1.0.16-2_amd64.deb ...
Unpacking libsodium23:amd64 (1.0.16-2) ...
Selecting previously unselected package libwebp6:amd64.
Preparing to unpack .../14-libwebp6_0.6.1-2_amd64.deb ...
Unpacking libwebp6:amd64 (0.6.1-2) ...
Selecting previously unselected package libxpm4:amd64.
Preparing to unpack .../15-libxpm4_1%3a3.5.12-1_amd64.deb ...
Unpacking libxpm4:amd64 (1:3.5.12-1) ...
Selecting previously unselected package libzip4:amd64.
Preparing to unpack .../16-libzip4_1.1.2-1.1_amd64.deb ...
Unpacking libzip4:amd64 (1.1.2-1.1) ...
Selecting previously unselected package lsphp73-common.
Preparing to unpack .../17-lsphp73-common_7.3.22-1+bionic_all.deb ...
Unpacking lsphp73-common (7.3.22-1+bionic) ...
Selecting previously unselected package lsphp73-json.
Preparing to unpack .../18-lsphp73-json_7.3.22-1+bionic_amd64.deb ...
Unpacking lsphp73-json (7.3.22-1+bionic) ...
Selecting previously unselected package lsphp73-opcache.
Preparing to unpack .../19-lsphp73-opcache_7.3.22-1+bionic_amd64.deb ...
Unpacking lsphp73-opcache (7.3.22-1+bionic) ...
Selecting previously unselected package lsphp73.
Preparing to unpack .../20-lsphp73_7.3.22-1+bionic_amd64.deb ...
Unpacking lsphp73 (7.3.22-1+bionic) ...
Selecting previously unselected package lsphp73-imap.
Preparing to unpack .../21-lsphp73-imap_7.3.22-1+bionic_amd64.deb ...
Unpacking lsphp73-imap (7.3.22-1+bionic) ...
Selecting previously unselected package lsphp73-mysql.
Preparing to unpack .../22-lsphp73-mysql_7.3.22-1+bionic_amd64.deb ...
Unpacking lsphp73-mysql (7.3.22-1+bionic) ...
Selecting previously unselected package rcs.
Preparing to unpack .../23-rcs_5.9.4-4_amd64.deb ...
Unpacking rcs (5.9.4-4) ...
Selecting previously unselected package openlitespeed.
Preparing to unpack .../24-openlitespeed_1.6.16-1+bionic_amd64.deb ...
Unpacking openlitespeed (1.6.16-1+bionic) ...
Selecting previously unselected package php-common.
Preparing to unpack .../25-php-common_1%3a60ubuntu1_all.deb ...
Unpacking php-common (1:60ubuntu1) ...
Selecting previously unselected package php7.2-common.
Preparing to unpack .../26-php7.2-common_7.2.24-0ubuntu0.18.04.6_amd64.deb ...
Unpacking php7.2-common (7.2.24-0ubuntu0.18.04.6) ...
Selecting previously unselected package php7.2-readline.
Preparing to unpack .../27-php7.2-readline_7.2.24-0ubuntu0.18.04.6_amd64.deb ...
Unpacking php7.2-readline (7.2.24-0ubuntu0.18.04.6) ...
Selecting previously unselected package php-readline.
Preparing to unpack .../28-php-readline_1%3a7.2+60ubuntu1_all.deb ...
Unpacking php-readline (1:7.2+60ubuntu1) ...
Setting up libhunspell-1.6-0:amd64 (1.6.2-1) ...
Setting up libaspell15:amd64 (0.60.7~20110707-4ubuntu0.1) ...
Setting up emacsen-common (2.0.8) ...
Setting up libjpeg-turbo8:amd64 (1.5.2-0ubuntu5.18.04.4) ...
Setting up rcs (5.9.4-4) ...
Setting up libzip4:amd64 (1.1.2-1.1) ...
Setting up libsodium23:amd64 (1.0.16-2) ...
Setting up mlock (8:2007f~dfsg-5ubuntu0.18.04.2) ...
Setting up lsphp73-common (7.3.22-1+bionic) ...
Setting up php-common (1:60ubuntu1) ...
Created symlink /etc/systemd/system/timers.target.wants/phpsessionclean.timer → /lib/systemd/system/phpsessionclean.timer.
Setting up libxpm4:amd64 (1:3.5.12-1) ...
Setting up libc-client2007e (8:2007f~dfsg-5ubuntu0.18.04.2) ...
Setting up libwebp6:amd64 (0.6.1-2) ...
Setting up libjpeg8:amd64 (8c-2ubuntu8) ...
Setting up php7.2-common (7.2.24-0ubuntu0.18.04.6) ...

Creating config file /etc/php/7.2/mods-available/calendar.ini with new version

Creating config file /etc/php/7.2/mods-available/ctype.ini with new version

Creating config file /etc/php/7.2/mods-available/exif.ini with new version

Creating config file /etc/php/7.2/mods-available/fileinfo.ini with new version

Creating config file /etc/php/7.2/mods-available/ftp.ini with new version

Creating config file /etc/php/7.2/mods-available/gettext.ini with new version

Creating config file /etc/php/7.2/mods-available/iconv.ini with new version

Creating config file /etc/php/7.2/mods-available/pdo.ini with new version

Creating config file /etc/php/7.2/mods-available/phar.ini with new version

Creating config file /etc/php/7.2/mods-available/posix.ini with new version

Creating config file /etc/php/7.2/mods-available/shmop.ini with new version

Creating config file /etc/php/7.2/mods-available/sockets.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvmsg.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvsem.ini with new version

Creating config file /etc/php/7.2/mods-available/sysvshm.ini with new version

Creating config file /etc/php/7.2/mods-available/tokenizer.ini with new version
Setting up dictionaries-common (1.27.2) ...
Setting up php7.2-readline (7.2.24-0ubuntu0.18.04.6) ...

Creating config file /etc/php/7.2/mods-available/readline.ini with new version
Setting up aspell (0.60.7~20110707-4ubuntu0.1) ...
Setting up hunspell-en-us (1:2017.08.24) ...
Setting up libenchant1c2a:amd64 (1.6.0-11.1) ...
Setting up php-readline (1:7.2+60ubuntu1) ...
Setting up aspell-en (2017.08.24-0-0.1) ...
Setting up enchant (1.6.0-11.1) ...
Setting up lsphp73 (7.3.22-1+bionic) ...

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/litespeed/php.ini with new version
Setting up lsphp73-mysql (7.3.22-1+bionic) ...

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/mysqli.ini with new version

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/pdo_mysql.ini with new version
Setting up lsphp73-imap (7.3.22-1+bionic) ...

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/imap.ini with new version
Setting up lsphp73-json (7.3.22-1+bionic) ...

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/json.ini with new version
Setting up lsphp73-opcache (7.3.22-1+bionic) ...

Creating config file /usr/local/lsws/lsphp73/etc/php/7.3/mods-available/opcache.ini with new version
Setting up openlitespeed (1.6.16-1+bionic) ...
Generating a RSA private key
...............+++++
.................................................................+++++
writing new private key to '/usr/local/lsws/admin/conf/webadmin.key'
-----
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for dictionaries-common (1.27.2) ...
aspell-autobuildhash: processing: en [en-common].
aspell-autobuildhash: processing: en [en-variant_0].
aspell-autobuildhash: processing: en [en-variant_1].
aspell-autobuildhash: processing: en [en-variant_2].
aspell-autobuildhash: processing: en [en-w_accents-only].
aspell-autobuildhash: processing: en [en-wo_accents-only].
aspell-autobuildhash: processing: en [en_AU-variant_0].
aspell-autobuildhash: processing: en [en_AU-variant_1].
aspell-autobuildhash: processing: en [en_AU-w_accents-only].
aspell-autobuildhash: processing: en [en_AU-wo_accents-only].
aspell-autobuildhash: processing: en [en_CA-variant_0].
aspell-autobuildhash: processing: en [en_CA-variant_1].
aspell-autobuildhash: processing: en [en_CA-w_accents-only].
aspell-autobuildhash: processing: en [en_CA-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-ise-w_accents-only].
aspell-autobuildhash: processing: en [en_GB-ise-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-ize-w_accents-only].
aspell-autobuildhash: processing: en [en_GB-ize-wo_accents-only].
aspell-autobuildhash: processing: en [en_GB-variant_0].
aspell-autobuildhash: processing: en [en_GB-variant_1].
aspell-autobuildhash: processing: en [en_US-w_accents-only].
aspell-autobuildhash: processing: en [en_US-wo_accents-only].

最新のphp7.4をインストール

ubuntu@i-11100000125436:/tmp$ sudo apt install lsphp74 lsphp74-curl lsphp74-imagick lsphp74-json lsphp74-mysql lsphp74-opcache
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  grub-pc-bin
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  fontconfig-config fonts-dejavu-core fonts-droid-fallback fonts-noto-mono ghostscript gsfonts imagemagick-6-common
  libavahi-client3 libavahi-common-data libavahi-common3 libcups2 libcupsfilters1 libcupsimage2 libfftw3-double3
  libfontconfig1 libgomp1 libgs9 libgs9-common libijs-0.35 libjbig0 libjbig2dec0 liblcms2-2 liblqr-1-0 libltdl7
  libmagickcore-6.q16-3 libmagickwand-6.q16-3 libonig4 libpaper-utils libpaper1 libtiff5 lsphp74-common poppler-data
  ttf-dejavu-core
Suggested packages:
  fonts-noto ghostscript-x cups-common libfftw3-bin libfftw3-dev liblcms2-utils libmagickcore-6.q16-3-extra php-pear
  php-user-cache poppler-utils fonts-japanese-mincho | fonts-ipafont-mincho fonts-japanese-gothic
  | fonts-ipafont-gothic fonts-arphic-ukai fonts-arphic-uming fonts-nanum
The following NEW packages will be installed:
  fontconfig-config fonts-dejavu-core fonts-droid-fallback fonts-noto-mono ghostscript gsfonts imagemagick-6-common
  libavahi-client3 libavahi-common-data libavahi-common3 libcups2 libcupsfilters1 libcupsimage2 libfftw3-double3
  libfontconfig1 libgomp1 libgs9 libgs9-common libijs-0.35 libjbig0 libjbig2dec0 liblcms2-2 liblqr-1-0 libltdl7
  libmagickcore-6.q16-3 libmagickwand-6.q16-3 libonig4 libpaper-utils libpaper1 libtiff5 lsphp74 lsphp74-common
  lsphp74-curl lsphp74-imagick lsphp74-json lsphp74-mysql lsphp74-opcache poppler-data ttf-dejavu-core
0 upgraded, 39 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.9 MB of archives.
After this operation, 114 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-common all 7.4.10-1+bionic [32.0 kB]
Get:2 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-json amd64 7.4.10-1+bionic [19.2 kB]
Get:3 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-opcache amd64 7.4.10-1+bionic [196 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 fonts-droid-fallback all 1:6.0.1r16-1.1 [1805 kB]
Get:5 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74 amd64 7.4.10-1+bionic [8579 kB]
Get:6 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-curl amd64 7.4.10-1+bionic [31.5 kB]
Get:7 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-imagick amd64 3.4.4-2+bionic [90.3 kB]
Get:8 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgomp1 amd64 8.4.0-1ubuntu1~18.04 [76.5 kB]
Get:9 http://rpms.litespeedtech.com/debian bionic/main amd64 lsphp74-mysql amd64 7.4.10-1+bionic [44.3 kB]
Get:10 http://archive.ubuntu.com/ubuntu bionic/main amd64 libfftw3-double3 amd64 3.3.7-1 [735 kB]
Get:11 http://archive.ubuntu.com/ubuntu bionic/main amd64 fonts-dejavu-core all 2.37-1 [1041 kB]
Get:12 http://archive.ubuntu.com/ubuntu bionic/main amd64 fontconfig-config all 2.12.6-0ubuntu2 [55.8 kB]
Get:13 http://archive.ubuntu.com/ubuntu bionic/main amd64 libfontconfig1 amd64 2.12.6-0ubuntu2 [137 kB]
Get:14 http://archive.ubuntu.com/ubuntu bionic/main amd64 libjbig0 amd64 2.1-3.1build1 [26.7 kB]
Get:15 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 liblcms2-2 amd64 2.9-1ubuntu0.1 [139 kB]
Get:16 http://archive.ubuntu.com/ubuntu bionic/main amd64 liblqr-1-0 amd64 0.4.2-2.1 [27.7 kB]
Get:17 http://archive.ubuntu.com/ubuntu bionic/main amd64 libltdl7 amd64 2.4.6-2 [38.8 kB]
Get:18 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libtiff5 amd64 4.0.9-5ubuntu0.3 [153 kB]
Get:19 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 imagemagick-6-common all 8:6.9.7.4+dfsg-16ubuntu6.8 [60.0 kB]
Get:20 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmagickcore-6.q16-3 amd64 8:6.9.7.4+dfsg-16ubuntu6.8 [1616 kB]
Get:21 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libmagickwand-6.q16-3 amd64 8:6.9.7.4+dfsg-16ubuntu6.8 [294 kB]
Get:22 http://archive.ubuntu.com/ubuntu bionic/main amd64 poppler-data all 0.4.8-2 [1479 kB]
Get:23 http://archive.ubuntu.com/ubuntu bionic/main amd64 fonts-noto-mono all 20171026-2 [75.5 kB]
Get:24 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libavahi-common-data amd64 0.7-3.1ubuntu1.2 [22.1 kB]
Get:25 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libavahi-common3 amd64 0.7-3.1ubuntu1.2 [21.6 kB]
Get:26 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libavahi-client3 amd64 0.7-3.1ubuntu1.2 [25.2 kB]
Get:27 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcups2 amd64 2.2.7-1ubuntu2.8 [211 kB]
Get:28 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupsimage2 amd64 2.2.7-1ubuntu2.8 [18.6 kB]
Get:29 http://archive.ubuntu.com/ubuntu bionic/main amd64 libijs-0.35 amd64 0.35-13 [15.5 kB]
Get:30 http://archive.ubuntu.com/ubuntu bionic/main amd64 libjbig2dec0 amd64 0.13-6 [55.9 kB]
Get:31 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpaper1 amd64 1.1.24+nmu5ubuntu1 [13.6 kB]
Get:32 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgs9-common all 9.26~dfsg+0-0ubuntu0.18.04.13 [5092 kB]
Get:33 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libgs9 amd64 9.26~dfsg+0-0ubuntu0.18.04.13 [2263 kB]
Get:34 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 ghostscript amd64 9.26~dfsg+0-0ubuntu0.18.04.13 [51.0 kB]
Get:35 http://archive.ubuntu.com/ubuntu bionic/main amd64 gsfonts all 1:8.11+urwcyr1.0.7~pre44-4.4 [3120 kB]
Get:36 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 libcupsfilters1 amd64 1.20.2-0ubuntu3.1 [108 kB]
Get:37 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libonig4 amd64 6.7.0-1 [119 kB]
Get:38 http://archive.ubuntu.com/ubuntu bionic/main amd64 libpaper-utils amd64 1.1.24+nmu5ubuntu1 [8170 B]
Get:39 http://archive.ubuntu.com/ubuntu bionic/universe amd64 ttf-dejavu-core all 2.37-1 [2978 B]
Fetched 27.9 MB in 12s (2241 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package fonts-droid-fallback.
(Reading database ... 92026 files and directories currently installed.)
Preparing to unpack .../00-fonts-droid-fallback_1%3a6.0.1r16-1.1_all.deb ...
Unpacking fonts-droid-fallback (1:6.0.1r16-1.1) ...
Selecting previously unselected package libgomp1:amd64.
Preparing to unpack .../01-libgomp1_8.4.0-1ubuntu1~18.04_amd64.deb ...
Unpacking libgomp1:amd64 (8.4.0-1ubuntu1~18.04) ...
Selecting previously unselected package libfftw3-double3:amd64.
Preparing to unpack .../02-libfftw3-double3_3.3.7-1_amd64.deb ...
Unpacking libfftw3-double3:amd64 (3.3.7-1) ...
Selecting previously unselected package fonts-dejavu-core.
Preparing to unpack .../03-fonts-dejavu-core_2.37-1_all.deb ...
Unpacking fonts-dejavu-core (2.37-1) ...
Selecting previously unselected package fontconfig-config.
Preparing to unpack .../04-fontconfig-config_2.12.6-0ubuntu2_all.deb ...
Unpacking fontconfig-config (2.12.6-0ubuntu2) ...
Selecting previously unselected package libfontconfig1:amd64.
Preparing to unpack .../05-libfontconfig1_2.12.6-0ubuntu2_amd64.deb ...
Unpacking libfontconfig1:amd64 (2.12.6-0ubuntu2) ...
Selecting previously unselected package libjbig0:amd64.
Preparing to unpack .../06-libjbig0_2.1-3.1build1_amd64.deb ...
Unpacking libjbig0:amd64 (2.1-3.1build1) ...
Selecting previously unselected package liblcms2-2:amd64.
Preparing to unpack .../07-liblcms2-2_2.9-1ubuntu0.1_amd64.deb ...
Unpacking liblcms2-2:amd64 (2.9-1ubuntu0.1) ...
Selecting previously unselected package liblqr-1-0:amd64.
Preparing to unpack .../08-liblqr-1-0_0.4.2-2.1_amd64.deb ...
Unpacking liblqr-1-0:amd64 (0.4.2-2.1) ...
Selecting previously unselected package libltdl7:amd64.
Preparing to unpack .../09-libltdl7_2.4.6-2_amd64.deb ...
Unpacking libltdl7:amd64 (2.4.6-2) ...
Selecting previously unselected package libtiff5:amd64.
Preparing to unpack .../10-libtiff5_4.0.9-5ubuntu0.3_amd64.deb ...
Unpacking libtiff5:amd64 (4.0.9-5ubuntu0.3) ...
Selecting previously unselected package imagemagick-6-common.
Preparing to unpack .../11-imagemagick-6-common_8%3a6.9.7.4+dfsg-16ubuntu6.8_all.deb ...
Unpacking imagemagick-6-common (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Selecting previously unselected package libmagickcore-6.q16-3:amd64.
Preparing to unpack .../12-libmagickcore-6.q16-3_8%3a6.9.7.4+dfsg-16ubuntu6.8_amd64.deb ...
Unpacking libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Selecting previously unselected package libmagickwand-6.q16-3:amd64.
Preparing to unpack .../13-libmagickwand-6.q16-3_8%3a6.9.7.4+dfsg-16ubuntu6.8_amd64.deb ...
Unpacking libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Selecting previously unselected package poppler-data.
Preparing to unpack .../14-poppler-data_0.4.8-2_all.deb ...
Unpacking poppler-data (0.4.8-2) ...
Selecting previously unselected package fonts-noto-mono.
Preparing to unpack .../15-fonts-noto-mono_20171026-2_all.deb ...
Unpacking fonts-noto-mono (20171026-2) ...
Selecting previously unselected package libavahi-common-data:amd64.
Preparing to unpack .../16-libavahi-common-data_0.7-3.1ubuntu1.2_amd64.deb ...
Unpacking libavahi-common-data:amd64 (0.7-3.1ubuntu1.2) ...
Selecting previously unselected package libavahi-common3:amd64.
Preparing to unpack .../17-libavahi-common3_0.7-3.1ubuntu1.2_amd64.deb ...
Unpacking libavahi-common3:amd64 (0.7-3.1ubuntu1.2) ...
Selecting previously unselected package libavahi-client3:amd64.
Preparing to unpack .../18-libavahi-client3_0.7-3.1ubuntu1.2_amd64.deb ...
Unpacking libavahi-client3:amd64 (0.7-3.1ubuntu1.2) ...
Selecting previously unselected package libcups2:amd64.
Preparing to unpack .../19-libcups2_2.2.7-1ubuntu2.8_amd64.deb ...
Unpacking libcups2:amd64 (2.2.7-1ubuntu2.8) ...
Selecting previously unselected package libcupsimage2:amd64.
Preparing to unpack .../20-libcupsimage2_2.2.7-1ubuntu2.8_amd64.deb ...
Unpacking libcupsimage2:amd64 (2.2.7-1ubuntu2.8) ...
Selecting previously unselected package libijs-0.35:amd64.
Preparing to unpack .../21-libijs-0.35_0.35-13_amd64.deb ...
Unpacking libijs-0.35:amd64 (0.35-13) ...
Selecting previously unselected package libjbig2dec0:amd64.
Preparing to unpack .../22-libjbig2dec0_0.13-6_amd64.deb ...
Unpacking libjbig2dec0:amd64 (0.13-6) ...
Selecting previously unselected package libpaper1:amd64.
Preparing to unpack .../23-libpaper1_1.1.24+nmu5ubuntu1_amd64.deb ...
Unpacking libpaper1:amd64 (1.1.24+nmu5ubuntu1) ...
Selecting previously unselected package libgs9-common.
Preparing to unpack .../24-libgs9-common_9.26~dfsg+0-0ubuntu0.18.04.13_all.deb ...
Unpacking libgs9-common (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Selecting previously unselected package libgs9:amd64.
Preparing to unpack .../25-libgs9_9.26~dfsg+0-0ubuntu0.18.04.13_amd64.deb ...
Unpacking libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Selecting previously unselected package ghostscript.
Preparing to unpack .../26-ghostscript_9.26~dfsg+0-0ubuntu0.18.04.13_amd64.deb ...
Unpacking ghostscript (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Selecting previously unselected package gsfonts.
Preparing to unpack .../27-gsfonts_1%3a8.11+urwcyr1.0.7~pre44-4.4_all.deb ...
Unpacking gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Selecting previously unselected package libcupsfilters1:amd64.
Preparing to unpack .../28-libcupsfilters1_1.20.2-0ubuntu3.1_amd64.deb ...
Unpacking libcupsfilters1:amd64 (1.20.2-0ubuntu3.1) ...
Selecting previously unselected package libonig4:amd64.
Preparing to unpack .../29-libonig4_6.7.0-1_amd64.deb ...
Unpacking libonig4:amd64 (6.7.0-1) ...
Selecting previously unselected package libpaper-utils.
Preparing to unpack .../30-libpaper-utils_1.1.24+nmu5ubuntu1_amd64.deb ...
Unpacking libpaper-utils (1.1.24+nmu5ubuntu1) ...
Selecting previously unselected package lsphp74-common.
Preparing to unpack .../31-lsphp74-common_7.4.10-1+bionic_all.deb ...
Unpacking lsphp74-common (7.4.10-1+bionic) ...
Selecting previously unselected package lsphp74-json.
Preparing to unpack .../32-lsphp74-json_7.4.10-1+bionic_amd64.deb ...
Unpacking lsphp74-json (7.4.10-1+bionic) ...
Selecting previously unselected package lsphp74-opcache.
Preparing to unpack .../33-lsphp74-opcache_7.4.10-1+bionic_amd64.deb ...
Unpacking lsphp74-opcache (7.4.10-1+bionic) ...
Selecting previously unselected package lsphp74.
Preparing to unpack .../34-lsphp74_7.4.10-1+bionic_amd64.deb ...
Unpacking lsphp74 (7.4.10-1+bionic) ...
Selecting previously unselected package lsphp74-curl.
Preparing to unpack .../35-lsphp74-curl_7.4.10-1+bionic_amd64.deb ...
Unpacking lsphp74-curl (7.4.10-1+bionic) ...
Selecting previously unselected package lsphp74-imagick.
Preparing to unpack .../36-lsphp74-imagick_3.4.4-2+bionic_amd64.deb ...
Unpacking lsphp74-imagick (3.4.4-2+bionic) ...
Selecting previously unselected package lsphp74-mysql.
Preparing to unpack .../37-lsphp74-mysql_7.4.10-1+bionic_amd64.deb ...
Unpacking lsphp74-mysql (7.4.10-1+bionic) ...
Selecting previously unselected package ttf-dejavu-core.
Preparing to unpack .../38-ttf-dejavu-core_2.37-1_all.deb ...
Unpacking ttf-dejavu-core (2.37-1) ...
Setting up libgs9-common (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Setting up libgomp1:amd64 (8.4.0-1ubuntu1~18.04) ...
Setting up libpaper1:amd64 (1.1.24+nmu5ubuntu1) ...

Creating config file /etc/papersize with new version
Setting up imagemagick-6-common (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Setting up fonts-droid-fallback (1:6.0.1r16-1.1) ...
Setting up libpaper-utils (1.1.24+nmu5ubuntu1) ...
Setting up gsfonts (1:8.11+urwcyr1.0.7~pre44-4.4) ...
Setting up liblcms2-2:amd64 (2.9-1ubuntu0.1) ...
Setting up libjbig0:amd64 (2.1-3.1build1) ...
Setting up fonts-dejavu-core (2.37-1) ...
Setting up poppler-data (0.4.8-2) ...
Setting up libonig4:amd64 (6.7.0-1) ...
Setting up libtiff5:amd64 (4.0.9-5ubuntu0.3) ...
Setting up libfftw3-double3:amd64 (3.3.7-1) ...
Setting up fonts-noto-mono (20171026-2) ...
Setting up liblqr-1-0:amd64 (0.4.2-2.1) ...
Setting up libjbig2dec0:amd64 (0.13-6) ...
Setting up libltdl7:amd64 (2.4.6-2) ...
Setting up libijs-0.35:amd64 (0.35-13) ...
Setting up lsphp74-common (7.4.10-1+bionic) ...
root root 1733 /var/lib/php/sessions
Setting up libavahi-common-data:amd64 (0.7-3.1ubuntu1.2) ...
Setting up fontconfig-config (2.12.6-0ubuntu2) ...
Setting up ttf-dejavu-core (2.37-1) ...
Setting up libavahi-common3:amd64 (0.7-3.1ubuntu1.2) ...
Setting up libfontconfig1:amd64 (2.12.6-0ubuntu2) ...
Setting up libmagickcore-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Setting up libmagickwand-6.q16-3:amd64 (8:6.9.7.4+dfsg-16ubuntu6.8) ...
Setting up libavahi-client3:amd64 (0.7-3.1ubuntu1.2) ...
Setting up libcups2:amd64 (2.2.7-1ubuntu2.8) ...
Setting up lsphp74-imagick (3.4.4-2+bionic) ...
Setting up libcupsfilters1:amd64 (1.20.2-0ubuntu3.1) ...
Setting up libcupsimage2:amd64 (2.2.7-1ubuntu2.8) ...
Setting up libgs9:amd64 (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Setting up ghostscript (9.26~dfsg+0-0ubuntu0.18.04.13) ...
Setting up lsphp74 (7.4.10-1+bionic) ...

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/litespeed/php.ini with new version
Setting up lsphp74-mysql (7.4.10-1+bionic) ...

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/mysqli.ini with new version

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/pdo_mysql.ini with new version
Setting up lsphp74-opcache (7.4.10-1+bionic) ...

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/opcache.ini with new version
Setting up lsphp74-curl (7.4.10-1+bionic) ...

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/curl.ini with new version
Setting up lsphp74-json (7.4.10-1+bionic) ...

Creating config file /usr/local/lsws/lsphp74/etc/php/7.4/mods-available/json.ini with new version
Processing triggers for libc-bin (2.27-3ubuntu1.2) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...

管理画面のパスワードを設定する

ubuntu@i-11100000125436:/tmp$ sudo /usr/local/lsws/admin/misc/admpass.sh

Please specify the user name of administrator.
This is the user name required to login the administration Web interface.

User name [admin]: admin

Please specify the administrator's password.
This is the password required to login the administration Web interface.

Password:
Retype password:
Administrator's username/password is updated successfully!
Indigoの場合はファイアーウォール設定を行います
Indigoファイアーウォール7080
Indigoファイアーウォール7080

ファイアーウォールに自宅から7080番ポートに接続出来るように設定を追加します。

管理画面に接続します

https://インスタンスのIPアドレス:7080/
をブラウザで開きます

LiteSpeed管理画面
LiteSpeed管理画面

「管理画面のパスワードを設定する」の項で設定したユーザー名とパスワードを利用してログインする事が出来ます。
インストールの説明はここまで、詳細な設定は次回に続きます。

コメント

タイトルとURLをコピーしました